视觉论坛VISIONBBS_视觉之家VISIONHOME微信公众号:石鑫华视觉网

 找回密码
 注册会员
查看: 187|回复: 0

[原创] LabVIEW Vision图像处理开发宝典-第一章 概述-第三节 NI软件的兼容性-3.3 视觉软件的兼容性

[复制链接]
  • TA的每日心情
    擦汗
    10 小时前
  • 签到天数: 1989 天

    连续签到: 18 天

    [LV.Master]2000FPS

    发表于 2020-5-7 17:04:38 | 显示全部楼层 |阅读模式

    LabVIEW Vision图像处理开发宝典-第一章 概述-第三节 NI软件的兼容性-3.3 视觉软件的兼容性

    3.3 视觉软件的兼容性
    一般来讲,NI或者作者都是建议安装了某个版本的LabVIEW以后,也安装对应的视觉软件,例如安装了LabVIEW 2013后,建议安装VDM 2013、VBAI2013、VAS 2013.8等版本,这样各种兼容性问题会少许多,因为NI的软件不可能会面面具到的进行测试,就算当前版本都还有很多的Bug,因此他们也不可能去测试许多与其它老版本的兼容性问题。所以,如果允许,最好是安装相同的年份版本的软件。根据各工具包的发布说明来看,工具包,可以支持前面4代版本的LabVIEW,但是不能往后支持比当前工具包更新的LabVIEW版本,如VDM2014,是不支持LabVIEW2014的。
    对于VBAI、视觉助手中需要调用VI时,这时会面临一个情况,就是需要调用比当前软件旧一版本的VI,即VBAI2013只能调用LabVIEW 2012生成的VI。VBAI中调用的VI可以使用LabVIEW2013保存为早期版本12版的,也可以调用,需要重新编译一下;而视觉助手中调用VI,则没有这样的功能,只能使用LabVIEW2012进行开发,然后再调用,只是视觉助手调用VI的情况非常小,因为一般来讲,最后也是生成VI的,没必要再调用VI。
    NI VisionDevelopment Module 2013支持LabVIEW 2010、2011、2012以及2013及其相应的SP1版本以及fx patch补丁版本(这个可以通过查看Readme说明文档,或者在安装时可以在代码生成选项中看到只有LabVIEW2010以后的代码生成功能http://visionbbs.com/thread-1446-1-1.html;支持VisualStudio 2005 和2008;LabWindows™/CVI™ 8.1 及以后的版本。支持32位和64位的LabVIEW。支持Windows 8/Windows 7/Vista/XP (32-bit)/Server 2008 R2/Server 2003 R2(32-bit)等操作系统
    2 VDM 2013视觉助手代码生成
    VBAI支持LabVIEW2010、2011、2012以及2013(这个在说明文件中没有说明,但是在安装时,在LabVIEW API Support选项中,可以看到有LabVIEW 2010 32位到LabVIEW 2013 32位);仅支持32位的LabVIEW;支持Visual Studio 2005 和2008等;支持Windows 8 (64-bit and 32-bit)/7 (64-bit and 32-bit)/Vista (64-bitand 32-bit)/XP SP3/Server 2003 R2 (32-bit)/Server 2008 R2 (64-bit)等操作系统。
    3 VBAI支持API
    最新版的VAS视觉采集软件为2013.8版,其支持的操作系统为Windows8/7/Vista/XP SP3 (32-bit) SP2/Server 2008 R2/Server 2003 R2 (32-bit);支持的驱动及编程软件为:

    • NI-IMAQ and NI-IMAQdxLabVIEW 8.6及以后版本
    • NI-IMAQ I/OLabVIEW 2009及以后版本
    • LabWindows/CVI 8.1及以后版本
    • Microsoft Visual C/C++ 6.0及以后版本
    • Microsoft Visual Basic 6.0及以后版本
    • Microsoft Visual Studio .NET 2005 2008 (NI-IMAQ I/O除外)
    从说明文档中发现,其支持的LabVIEW版本相对较早。但是从其安装时的支持选项来看,与VDM、VBAI一样,也只支持到LabVIEW2010及以后的版本。
    4 VASLabVIEW支持
        经过上面的了解,NI的软件,与其它软件类似,支持主流的操作系统;所有工具包,支持与工具包相同的LabVIEW为宜。因此建议客户安装软件时,以相同年份的软件及工具包为准,以避免年份跨越太久而无法兼容。


    本帖子中包含更多资源

    您需要 登录 才可以下载或查看,没有帐号?注册会员

    x
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 注册会员

    本版积分规则

    LabVIEW图像处理教程
    机器视觉商城淘宝店铺
    视觉论坛充值赞助方法

    QQ|小黑屋|视觉论坛VISIONBBS.COM|视觉之家VISIONHOME.CN|东莞市华动智能科技有限公司 ( 粤ICP备17078359号-2 )|网站地图

    GMT+8, 2020-10-24 20:14

    Powered by shixinhua.com X3.4

    © 2009-2020 VISIONBBS.COM 浏览量:

    快速回复 返回顶部 返回列表