机器视觉论坛VISIONBBS_视觉之家VISIONHOME微信公众号:石鑫华视觉网

 找回密码
 注册会员
查看: 238|回复: 0

[NI驱动软件] NI-CAN 2.5.2 Driver Win32Eng NI控制器局域网驱动软件2.5.2下载

[复制链接]
  • TA的每日心情
    难过
    昨天 10:00
  • 签到天数: 2253 天

    连续签到: 3 天

    [LV.Master]2000FPS

    发表于 2021-1-2 22:37:37 | 显示全部楼层 |阅读模式

    注册登陆后可查看附件和大图,以及购买相关内容

    您需要 登录 才可以下载或查看,没有帐号?注册会员

    x
    Windows系统下(Linux和MAC系统下请自行了解清楚)NI的各种软件模块工具包驱动程序,使用NI许可证管理器来激活的,绝大部分的都可以使用NI Lincense Acvivator来激活,以下链接可下载:
    NI序列号Serial Number生成激活工具NI License Activator,LabVIEW/VBAI/VDM/VAS等软件模块工具包破解工具不限版本
    http://visionbbs.com/thread-490-1-1.html

    视觉论坛的各种资源,除了视觉相关的模块有使用外,大部分的都不会使用,所以仅提供资源不能提供技术支持。资源的下载地址一般会同时提供NI官方地址和百度网盘的下载地址。某些工具包NI的地址失效或没有NI的下载地址,那视觉论坛也没有办法,只能尝试使用百度网盘地址下载;如果百度网盘的下载地址失效过期,可联系论坛客服更新。现在NI的下载服务器对我国IP地址不是很友好,有些时候速度很慢或大的资源下载很容易出错,这样会造成安装过程各种类型报错而无法安装。建议在下载完成后,对下载资源做校验和验证(NI一般会提供MD5或SHA256等),与官方或视觉论坛提供的校验和对比,一致就可以安装,如果不一致,则需要重新下载。视觉论坛早期下载的资源,那时候NI没有这么多限制,基本上都是正常下载的资源;后期下载的资源,都与NI的正确校验和对比过,保证是正确的资源才上传到百度网盘,所以百度网盘的资源基本上是正确的。校验和工具下载地址:
    文件Hash计算器FHash,文件校验和验证下载文件正确性验证,MD5值计算、SHA1值计算、SHA256值计算、CRC32值计算
    http://visionbbs.com/thread-26524-1-1.html

    NI-CAN 2.5.2 Driver Win32Eng NI控制器局域网驱动软件2.5.2下载

    NI-CAN
    NI-CAN用于支持开发和部署多个控制器局域网(CAN)应用程序
    NI-CAN驱动软件适用于多种类型的CAN硬件应用程序,如高速CAN、容错CAN和LIN接口。NI-CAN具有强大的底层框架API和上层通道,可实现快速开发。NI-CAN用于为LabVIEW、LabWindows/CVI和ANSI C/C++提供本地支持。此外,NI-CAN还包括通道测试面板、总线监控器和记录器以及数据库编辑器等工具。LabWindows标志经Microsoft公司授权使用。Windows是Microsoft公司在美国和其他国家的注册商标。

    Win32Eng
    2.5.2
    文件名: NI-CAN\NI-CAN252.exe
    文件大小: 177191968 字节 (168.98 MB)
    修改日期: 2007-10-04 04:30
    MD5: 095aa45c76037cc80762bdfa0226a35c(官方正确)
    SHA1: 607fc8d27759c761205dd1ba9aae883af6a2c97a
    SHA256: 0a981ef8a37ebef5e75a862ead12300a7c41e4c2a7c8baafc9c53bc6e5860449
    CRC32: 81175c7c

    百度网盘和NI官方下载地址:
    CAN2.5.2.txt (574 Bytes, 下载次数: 0, 售价: 2 快钱)

    NI-CAN 2.5.2 Readme
    September 2007
    ni.com/support
    This file contains information on the NI-CANTM Software for Windows 2000/Vista/XP and LabVIEWTM Real-Time (RT). Information in this file is organized in the following sections:
    • Supported Platforms
    • Installing NI-CAN 2.5.2
    • Documentation
    • New Features as Compared to 2.5
    • Bug Fixes
    • Additional Programming Topics
    • Release Notes

    Installing NI-CAN 2.5.2
    Before installing the NI-CAN software, log on as Administrator or as a user with Administrator privileges. The NI-CAN software setup program must have Administrator privileges because the program modifies the configuration registry of your system. Complete the following steps to install the NI-CAN software.
    • Insert the NI-CAN software CD into your CD-ROM drive. The installer launches if your CD-ROM drive plays data CDs automatically. If the installer does not launch automatically, navigate to the CD using Windows Explorer and launch the autorun.exe file from your NI-CAN Software CD.
    • The installation wizard guides you through the necessary steps to install the NI-CAN software. You can go back and change values where appropriate by clicking the Back button. You can exit the setup where appropriate by clicking Cancel.
    • When the installation is complete, click Finish.
    Installing NI-CAN Silently
    You can control programmatically which features in the NI-CAN distribution to enable or disable for installation. You therefore can install a subset of the NI-CAN distribution silently. Refer to the template_spec.txt file in the specfiles directory on the NI-CAN CD for more information about installing NI-CAN silently and selecting which features to install automatically.
    Back to Top

    Supported PlatformsSupported Operating Systems
    You must install and run this version of the NI-CAN software on the following operating systems:
    • Windows 2000 Service Pack 3 (or newer)
    • Windows XP, 32-bit
    • Windows Vista (32-bit and 64-bit)
      For more information on using National Instruments hardware and software products with Windows Vista, visit ni.com/vista.
    National Instruments recomends using Service Pack 2 when using the USB-847x interfaces in hyper-thread or multi-core/cpu environments on Microsoft Windows XP.
    Supported Hardware
    This version of the NI-CAN software supports the following National Instruments hardware products on Windows and LabVIEW RT:
    • PCI-CAN, PCI-CAN/2 (High-Speed; Series 1 and 2)
    • PCI-CAN/LS, PCI-CAN/LS2 (Low-Speed/Fault-Tolerant; Series 1 and 2)
    • PCI-CAN/DS, (Dual Speed: Port-1 High-Speed, Port-2 Low-Speed; Series 1)
    • PCI-CAN/XS, PCI-CAN/XS2, (Software-Selectable HS/LS/SW; Series 2)
    • PXI-8460, one-port or two-port (Low-Speed/Fault-Tolerant; Series 1 and 2)
    • PXI-8461, one-port or two-port (High-Speed; Series 1 and 2)
    • PXI-8462, (Dual Speed: Port-1 High-Speed, Port-2 Low-Speed; Series 1)
    • PXI-8464, one-port or two-port (Software- Selectable HS/LS/SW; Series 2)
    This version of the NI-CAN software supports the following National Instruments hardware products on Windows:
    • USB-8472 (Low-Speed/Fault-Tolerant CAN)
    • USB-8472s (Low-Speed/Fault-Tolerant CAN with synchronization)
    • USB-8473 (High-Speed CAN)
    • USB-8473s (High-Speed CAN with synchronization)
    • USB-8476 (LIN)
    • USB-8476s (LIN with synchronization)
    • PCMCIA-CAN, PCMCIA-CAN/2 (Series 1 and 2)
    Please note: PCMCIA-CAN and PCMCIA-CAN/2 interfaces are not supported on the 64-bit version of Windows Vista!
    Several National Instruments Series 1 CAN hardware are not supported in this version of NI-CAN. Install NI-CAN version 2.2 for support of the following hardware products (available on ni.com):
    • PCI-CAN, (pre-1998 CAN card, part numbers: 183887A-01, 183887B-01)
    • PCI-CAN/2, (pre-1998 CAN card, part numbers: 183887A-02, 183887B-02)
    • PCMCIA-CAN, (pre-1998 CAN card, part numbers: 184272A-01, 184272B-01, 184272C-01)
    • PCMCIA-CAN/2, (pre-1998 CAN card, part numbers: 184272A-02, 184272B-02, 184272C-02)
    Install NI-CAN version 2.1.3 for support of the following AT (ISA) hardware products (available on ni.com):
    • AT-CAN
    • AT-CAN/2, (ISAPNP cards; High Speed; Series 1)
    The NI-CAN software supports only National Instruments CAN hardware products. For information about software for CAN products from other vendors, refer to the documentation you received with those products.
    Supported Development Environments
    This version of the NI-CAN software supports the following development environments:
    • LabVIEW 7.1, 8.0, 8.2, and 8.5
    • LabVIEW Real-Time (RT) 7.1, 8.0, 8.2, and 8.5
    • LabWindows/CVI 7.1 and higher
    • Microsoft Visual Basic 6.0
    • Microsoft Visual C/C++ 6.0
    • Borland C/C++
    Back to Top

    Documentation
    The Installation Guide: CAN Hardware and NI-CAN Software for Windows document included with the NI-CAN CD provides instructions for installing National Instruments CAN hardware and software.
    The NI-CAN Hardware and Software Manual is the primary document for NI CAN products. This manual includes an introduction to CAN, specifications for hardware, information on how to get started with application development, and a complete reference for all NI-CAN functions.
    The NI-CAN Hardware and Software Manual is provided in Adobe Acrobat Portable Document Format (PDF). You can download the Acrobat Reader for free at: www.adobe.com.
    Open the manual from your Start menu in:

      Start » All Programs » National Instruments » NI-CAN
    Links to the NI-CAN Hardware and Software Manual are provided in the online help for each NI-CAN function within the National Instruments LabVIEW and Lab Windows/CVITM development environments.
    Online help for the NI-CAN features within Measurement & Automation Explorer (MAX) is located in the MAX Help Topics menu. The MAX Help Topics for NI-CAN also include a link to the NI-CAN Hardware and Software Manual.
    Back to Top

    New Features as Compared to NI-CAN 2.5
    The NI-CAN 2.5.1 release adds the following features:
    • Added support for LabVIEW 8.5.
    Back to Top

    Bug Fixes
    The following items are changes from NI-CAN 2.5 to NI-CAN 2.5.1
    Bug IDFixed Issue
    47P90370Fixed an issue where the LIN firmware was incorrectly calculating the enhanced checksum using the unprotected ID.
    47ICPNSPFixed an issue where CAN objects would not restart correctly when the Network Interface is restarted.
    48H8PQ70Fixed an issue where the computer would crash when the function SetProcessWorkingSetSize() is used to increase buffer memory.
    The following items are changes from NI-CAN 2.5.1 to NI-CAN 2.5.2
    Bug IDFixed Issue
    4DAGR870NI-CAN 2.5.1 does not install VIs to support synchronization between Traditional NI-DAQ and CAN for LabVIEW 8.5.
    Back to Top

    Additional Programming TopicsSupport of CANdb (*.DBC) Files
    NI-CAN provides support for CANdb network files created using the Vector CANdb or CANdb++ editor. The information from the CANdb file can be used in the Measurement & Automation Explorer (MAX) or with the NI-CAN Channel API. For more information, refer to the Using the Channel API chapter in the NI-CAN Hardware and Software Manual.
    NI-CAN supports CANdb network files created using the CAN module of Vector products. NI-CAN does not provide complete support of CANdb files created using modules for higher-layer CAN protocols, such as J1939, ISO11783, or NMEA2000. In order to view the set of features supported for these modules, import the CANdb file into MAX. NI-CAN will display an error dialog for any unsupported object, and will display those objects with a red mark. For example, the J1939 protocol for multi-frame messages (greater than 8 bytes) is not supported in the current version of NI-CAN.
    Updating get/Set Attribute in Frame API for LabVIEW
    NI-CAN 2.4 (or newer) includes several new Frame API attributes. If you have a LabVIEW VI written for an earlier version of NI-CAN, upgrading to NI-CAN 2.4 (or newer) will not automatically update constants or controls for the AttrId input. To use the new attributes, replace your older constants and controls using the AttrId input of the updated NI-CAN VIs.
    If you do not want to use new Frame API attributes, you can continue to use the older constants and controls for compatibility.
    This issue does not apply to the Channel API for LabVIEW. Because the Get/Set Property functions are provided as polymorphic VIs, they are automatically updated.
    Back to Top

    Release Notes
    • For USB-LIN interfaces, the LIN bus must be terminated. This is typically done at the master node. For information on how to enable or disable termination on the USB-LIN, refer to the ncSetAttribute attribute function with the Frame API.
    • The USB-LIN interfaces require external power from 8-18V. For more details on the power requirements, refer to the USB-LIN specifications sections within the NI-CAN Hardware and Software Manual.
    • The USB LED will quickly switch between green and amber when the hardware is first detected.
    • Fatal errors may cause the USB LED to flash in an error code pattern. Count the number of long and short flashes, then contact National Instruments support.
    • If using the USB CAN or LIN products with a USB hub, the hub must be powered.
    • Due to the inherent latencies of the Universal Serial Bus (USB), data or states received by the NI USB 847x Series devices might be processed by the driver on the host side later than data from a plug-in (PCI, PXI, PCMCIA) interface. This does not affect the timestamps as those are generated on the hardware, but could cause time-out failures with the NI USB 847x Series devices that won't happen on plug-in hardware. To avoid those, increase the timeout value for functions that perform a wait for a certain state.
    Back to Top


    © 1996-2007 National Instruments Corporation. All rights reserved.
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 注册会员

    本版积分规则

    LabVIEW图像处理教程
    机器视觉商城淘宝店铺
    视觉论坛充值赞助方法

    QQ|机器视觉论坛VISIONBBS.COM|视觉之家VISIONHOME.CN|东莞市华动智能科技有限公司 ( 粤ICP备17078359号-2 )|网站地图

    GMT+8, 2021-7-29 10:02

    Powered by shixinhua.com X3.4

    © 2009-2021 VISIONBBS.COM 浏览量:

    快速回复 返回顶部 返回列表